using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\t\K(.+?)(?=\t)";
string substitution = @"[url=http://www.website.com/personell/$1]$1[/url]";
string input = @"2012 Mark Dept other
2010 Louanne Dept other
2009 Jannett Dept other";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}