use strict;
my $str = '2012 Mark Dept other
2010 Louanne Dept other
2009 Jannett Dept other';
my $regex = qr/^\d+\t\K(.+?)(?=\t)/mp;
my $subst = '[url=http://www.website.com/personell/$1]$1[/url]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";