$re = '/^\d+\t\K(.+?)(?=\t)/m';
$str = '2012 Mark Dept other
2010 Louanne Dept other
2009 Jannett Dept other';
$subst = "[url=http://www.website.com/personell/$1]$1[/url]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;