import Foundation
let pattern = #"^\d+\t\K(.+?)(?=\t)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2012 Mark Dept other
2010 Louanne Dept other
2009 Jannett Dept other
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[url=http://www.website.com/personell/$1]$1[/url]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)