const regex = /^\d+\t\K(.+?)(?=\t)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\t\\K(.+?)(?=\\t)', 'gm')
const str = `2012 Mark Dept other
2010 Louanne Dept other
2009 Jannett Dept other`;
const subst = `[url=http://www.website.com/personell/$1]$1[/url]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);