#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d+\t\K(.+?)(?=\t)"
Local $sString = "2012 Mark Dept other" & @CRLF & _
"2010 Louanne Dept other" & @CRLF & _
"2009 Jannett Dept other"
Local $sSubst = "[url=http://www.website.com/personell/$1]$1[/url]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)