# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(?:(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d))/ /g;t' <<< "subject101
street45"