use strict;
my $str = 'subject101
street45';
my $regex = qr/(?i)(?:(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d))/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";