using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d))";
string substitution = @" ";
string input = @"subject101
street45";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}