import re
regex = re.compile(r"(?i)(?:(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d))")
test_str = ("subject101\n"
" street45")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)