$re = '/(?i)(?:(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d))/';
$str = 'subject101
street45';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;