#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d))"
Local $sString = "subject101" & @CRLF & _
" street45"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)