const regex = new RegExp('(?i)(?:(?<=\\d)(?=[a-z])|(?<=[a-z])(?=\\d))', 'g')
const str = `subject101
street45`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);