#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) \^https:\/\/drive\.google\.com\/.+\/folders\/([A-Za-z0-9_-]+=?)$/"
Local $sString = "https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")