import re
regex = re.compile(r" \^https:\/\/drive\.google\.com\/.+\/folders\/([A-Za-z0-9_-]+=?)$/", flags=re.MULTILINE)
test_str = ("https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")