re = / \^https:\/\/drive\.google\.com\/.+\/folders\/([A-Za-z0-9_-]+=?)$\//m
str = 'https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end