package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) \^https:\/\/drive\.google\.com\/.+\/folders\/([A-Za-z0-9_-]+=?)$/`)
var str = `https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}