const regex = new RegExp(' \\^https:\\/\\/drive\\.google\\.com\\/.+\\/folders\\/([A-Za-z0-9_-]+=?)$/', 'm')
const str = `https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}