import Foundation
let pattern = #" \^https:\/\/drive\.google\.com\/.+\/folders\/([A-Za-z0-9_-]+=?)$/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}