$re = '/ \^https:\/\/drive\.google\.com\/.+\/folders\/([A-Za-z0-9_-]+=?)$//m';
$str = 'https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);