import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">.*?([^<]+)";
final String string = "<a rel=\"profile-edit\" class=\"app js-user-name\" href=\"/profile/0471482493?from_my_profile=1\">Mia</a></b> <";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}