$re = '/>.*?([^<]+)/';
$str = '<a rel="profile-edit" class="app js-user-name" href="/profile/0471482493?from_my_profile=1">Mia</a></b> <';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;