// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r">.*?([^<]+)").unwrap();
let string = "<a rel=\"profile-edit\" class=\"app js-user-name\" href=\"/profile/0471482493?from_my_profile=1\">Mia</a></b> <";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}