#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)(?<!\bDim\s+)day(s)?(?!\S)"
Local $sString = "'*** This day is the day of all days" & @CRLF & _
" '*** This day is the day of all days (there are 4 spaces at the start)" & @CRLF & _
" Dim day as integer" & @CRLF & _
" day=day+1"
Local $sSubst = "night$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)