using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?<!\bDim\s+)day(s)?(?!\S)";
string substitution = @"night$1";
string input = @"'*** This day is the day of all days
'*** This day is the day of all days (there are 4 spaces at the start)
Dim day as integer
day=day+1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}