import Foundation
let pattern = #"(?<!\S)(?<!\bDim\s+)day(s)?(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'*** This day is the day of all days
'*** This day is the day of all days (there are 4 spaces at the start)
Dim day as integer
day=day+1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"night$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)