const regex = new RegExp('(?<!\\S)(?<!\\bDim\\s+)day(s)?(?!\\S)', 'gm')
const str = `'*** This day is the day of all days
'*** This day is the day of all days (there are 4 spaces at the start)
Dim day as integer
day=day+1`;
const subst = `night$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);