import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?<!\\bDim\\s+)day(s)?(?!\\S)";
final String string = "'*** This day is the day of all days\n"
+ " '*** This day is the day of all days (there are 4 spaces at the start)\n"
+ " Dim day as integer\n"
+ " day=day+1";
final String subst = "night$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}