re = /(?<!\S)(?<!\bDim\s+)day(s)?(?!\S)/m
str = '\'*** This day is the day of all days
\'*** This day is the day of all days (there are 4 spaces at the start)
Dim day as integer
day=day+1'
subst = 'night$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result