use strict;
my $str = '\'*** This day is the day of all days
\'*** This day is the day of all days (there are 4 spaces at the start)
Dim day as integer
day=day+1';
my $regex = qr/(?<!\S)(?<!\bDim\s+)day(s)?(?!\S)/mp;
my $subst = 'night$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";