# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(?<!\bDim\s+)day(s)?(?!\S)"
test_str = ("'*** This day is the day of all days\n"
" '*** This day is the day of all days (there are 4 spaces at the start)\n"
" Dim day as integer\n"
" day=day+1")
subst = "night$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.