# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^,]+)\s*,\s*([^,]*?)\s*,\s*(.*?)\s*/\1,\2,\3/gm;t' <<< "university of washington, seattle, washington
university of washington, seattle , washington
university of washington, , washington
university of washington, seattle, washington
university of new york,ny , usa
university of new york,new york , usa
university of new york, new york , usa"