#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^,]+)\s*,\s*([^,]*?)\s*,\s*(.*?)\s*"
Local $sString = "university of washington, seattle, washington" & @CRLF & _
"university of washington, seattle , washington" & @CRLF & _
"university of washington, , washington" & @CRLF & _
"university of washington, seattle, washington" & @CRLF & _
"university of new york,ny , usa" & @CRLF & _
"university of new york,new york , usa" & @CRLF & _
"university of new york, new york , usa"
Local $sSubst = "\1,\2,\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)