import Foundation
let pattern = #"([^,]+)\s*,\s*([^,]*?)\s*,\s*(.*?)\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
university of washington, seattle, washington
university of washington, seattle , washington
university of washington, , washington
university of washington, seattle, washington
university of new york,ny , usa
university of new york,new york , usa
university of new york, new york , usa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1,\2,\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)