using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,]+)\s*,\s*([^,]*?)\s*,\s*(.*?)\s*";
string substitution = @"\1,\2,\3";
string input = @"university of washington, seattle, washington
university of washington, seattle , washington
university of washington, , washington
university of washington, seattle, washington
university of new york,ny , usa
university of new york,new york , usa
university of new york, new york , usa";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}