package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^,]+)\s*,\s*([^,]*?)\s*,\s*(.*?)\s*`)
var str = `university of washington, seattle, washington
university of washington, seattle , washington
university of washington, , washington
university of washington, seattle, washington
university of new york,ny , usa
university of new york,new york , usa
university of new york, new york , usa`
var substitution = "\1,\2,\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}