use strict;
my $str = 'university of washington, seattle, washington
university of washington, seattle , washington
university of washington, , washington
university of washington, seattle, washington
university of new york,ny , usa
university of new york,new york , usa
university of new york, new york , usa';
my $regex = qr/([^,]+)\s*,\s*([^,]*?)\s*,\s*(.*?)\s*/mp;
my $subst = '\\1,\\2,\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";