const regex = new RegExp('([^,]+)\\s*,\\s*([^,]*?)\\s*,\\s*(.*?)\\s*', 'gm')
const str = `university of washington, seattle, washington
university of washington, seattle , washington
university of washington, , washington
university of washington, seattle, washington
university of new york,ny , usa
university of new york,new york , usa
university of new york, new york , usa`;
const subst = `\1,\2,\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);