re = /([^,]+)\s*,\s*([^,]*?)\s*,\s*(.*?)\s*/m
str = 'university of washington, seattle, washington
university of washington, seattle , washington
university of washington, , washington
university of washington, seattle, washington
university of new york,ny , usa
university of new york,new york , usa
university of new york, new york , usa'
subst = '\\1,\\2,\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result