# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,?(-?\d+(?:[.,]\d+)?)(?=.*\1)//gm;t' <<< "0,0,67,67,0
-30,-30
1.46,1.46
67,67,67,67,67,67,0,0,0,0,0,0,67,67,67,67,67,67"