import Foundation
let pattern = #",?(-?\d+(?:[.,]\d+)?)(?=.*\1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0,0,67,67,0
-30,-30
1.46,1.46
67,67,67,67,67,67,0,0,0,0,0,0,67,67,67,67,67,67
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)