const regex = /,?(-?\d+(?:[.,]\d+)?)(?=.*\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',?(-?\\d+(?:[.,]\\d+)?)(?=.*\\1)', 'gm')
const str = `0,0,67,67,0
-30,-30
1.46,1.46
67,67,67,67,67,67,0,0,0,0,0,0,67,67,67,67,67,67`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);