$re = '/,?(-?\d+(?:[.,]\d+)?)(?=.*\1)/m';
$str = '0,0,67,67,0
-30,-30
1.46,1.46
67,67,67,67,67,67,0,0,0,0,0,0,67,67,67,67,67,67';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;