# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r",?(-?\d+(?:[.,]\d+)?)(?=.*\1)"
test_str = ("0,0,67,67,0\n"
"-30,-30\n"
"1.46,1.46\n"
"67,67,67,67,67,67,0,0,0,0,0,0,67,67,67,67,67,67")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.