import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",?(-?\\d+(?:[.,]\\d+)?)(?=.*\\1)";
final String string = "0,0,67,67,0\n"
+ "-30,-30\n"
+ "1.46,1.46\n"
+ "67,67,67,67,67,67,0,0,0,0,0,0,67,67,67,67,67,67";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}