re = /,?(-?\d+(?:[.,]\d+)?)(?=.*\1)/m
str = '0,0,67,67,0
-30,-30
1.46,1.46
67,67,67,67,67,67,0,0,0,0,0,0,67,67,67,67,67,67'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result