# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(\.+|[[:punct:]])(?<!\b['’]\b)\s*/ \1 /gm;t' <<< "I want: spaces around all these marks;:!?.but i didn’t want it there in didn't"