using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\.+|[[:punct:]])(?<!\b['’]\b)\s*";
string substitution = @" \1 ";
string input = @"I want: spaces around all these marks;:!?.but i didn’t want it there in didn't";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}