use strict;
my $str = 'I want: spaces around all these marks;:!?.but i didn’t want it there in didn\'t';
my $regex = qr/\s*(\.+|[[:punct:]])(?<!\b['’]\b)\s*/mp;
my $subst = ' \\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";