import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\\.+|[[:punct:]])(?<!\\b['’]\\b)\\s*";
final String string = "I want: spaces around all these marks;:!?.but i didn’t want it there in didn't";
final String subst = " \\1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}